Jared on Tech

rss

Jared Shockley, Information Technology Professional This is my spot on the Internet for me to share my thoughts on technology, software, hardware, gadgets and IT in general. Please feel free to comment.


Windows 8, the Mail App, and CA Roots

I know I am a big-time geek. I use my TechNet subscription from Microsoft and run many servers at home since I am not always very technical at my job as Director of IT. It is a management position, not a technical position. In setting up Windows 8 on my ASUS EP121, I wanted to use the Mail App to check on my personal mail accounts. I do have several and hoped to get the main boxes into the app. It has been a fight to get one account on and using a troubleshooting tool to get it done. Here's the info on all this …

As I stated, I have a TechNet account and run many of my own servers as testing grounds for Microsoft technologies. One of these servers is an Exchange 2010 system for e-mail. I also have my own Active Directory for my home network along with my own internal Certificate Authority for SSL Certificates. By importing the CA root, I can create certificates for my internal systems and websites. I implemented my own CA root and have my Exchange server utilizing it for its SSL certificates.

After installing the Consumer Preview of Windows 8, I tried to setup my personal Exchange account to the Mail App. After spending about 2 hours on the issue, I could not get a connection. I was tired of hitting my head against the wall and ended up connecting to my Windows 7 desktop using Outlook 2010. *sigh*

I was hoping that the Release Preview of Windows 8 and the apps would fix this. I was wrong. Hitting the forums and answers sites, I am finding I was not the only one. Many people fixed this by buying SSL certificates from a public CA like GoDaddy, Comodo or VeriSign. I was determined not to have to do this. If Microsoft wanted to support enterprise users, this is a need. They will want to use Win RT to connect to their work mail servers and many companies use their own CA.

After posting into the Answers forum, I got a PM from one of the forum moderators and a person working with Microsoft, either a vendor or Blue Badge. They wanted more information and to have me run some tools. In the course of several contacts, I did exactly what they asked and provided more and more logs. Eventually, they said that it was definitely a problem with my SSL Certificate and would I run Fiddler to look and see what the problem is. I installed the Beta copy of Fiddler for Windows 8 (v4.3.9.9 beta) and installed the Win 8 Loopback Extensions to capture the Metro app. Post installation of Fiddler and its add-on, I fired up Mail. To my amazement, it connected and synced my mail, calendar, and contacts. Everything was working as it should normally. A quick run through of my settings in Fiddler to ensure I was not ignoring SSL problems and a couple of other tests, I found myself with a working Mail app.

After reporting this to the forum moderator, I still not have heard anything from him other than "we are still working on the issue" posts. I find it an interesting solution to this issue. I wonder if this has anything to do with known SSL/HTTPS issues in MetroTwit on the Windows 8 Desktop. I also can say that the Metro IE will not pull up HTTPS pages properly but they work in the Desktop version of IE 10. I hope they fix some of these protocol oddities soon as the release to manufacturing is around the corner.

Jared

UPDATE 1: I also found that the Skydrive app does not work with Fiddler running and working for the Mail App in my case. More information on this issue is located at the Microsoft Answers Page on the issue.




Comments are closed.
Showing 0 Comment